Issue with crypto withdrawals
Resolved

All systems are working. We are actively monitoring the current status.

Tue, May 7, 2024, 10:50 AM
7 months ago
Affected components

No components marked as affected

Updates

Resolved

All systems are working. We are actively monitoring the current status.

Tue, May 7, 2024, 10:50 AM
1d earlier...

Monitoring

We have fixed another issue which was impacting some users withdrawals. Systems are operating normally now.

Mon, May 6, 2024, 02:42 AM
1d earlier...

Monitoring

Withdrawals are being processed. We found the issue and we were able to fix it. We will be monitoring the system for the next hours.

Sat, May 4, 2024, 07:11 PM
1h earlier...

Investigating

We are investigating an issue which is blocking users to send withdrawals.

Funds are safe.

Sat, May 4, 2024, 05:33 PM