Connectivity issues
Resolved

All systems are working. We are actively monitoring the current status.

Sat, May 4, 2024, 12:17 PM
8 months ago
Affected components

No components marked as affected

Updates

Resolved

All systems are working. We are actively monitoring the current status.

Sat, May 4, 2024, 12:17 PM
53m earlier...

Investigating

We are currently investigating connectivity issues with our web platform.

Sat, May 4, 2024, 11:23 AM