Ethereum payment processing delays for Trading Account
Resolved

All systems are working. We are actively monitoring the current status.

Mon, Apr 29, 2024, 01:07 AM
8 months ago
Affected components

No components marked as affected

Updates

Resolved

All systems are working. We are actively monitoring the current status.

Mon, Apr 29, 2024, 01:07 AM
3h earlier...

Monitoring

Our team has deployed a fix, our systems should catch up with the network soon

Sun, Apr 28, 2024, 09:58 PM
2h earlier...

Investigating

Our Ethereum payments processing infrastructure is experiencing issues which is causing transaction processing delay for Trading Account. Our team is working on resolution. All funds are safe

Sun, Apr 28, 2024, 07:50 PM