BTC Withdrawal Issues
Resolved

All systems are working. We are actively monitoring the current status.

Wed, Apr 10, 2024, 12:28 PM
8 months ago
Affected components

No components marked as affected

Updates

Resolved

All systems are working. We are actively monitoring the current status.

Wed, Apr 10, 2024, 12:28 PM
2d earlier...

Identified

We have identified some issues affecting certain users when attempting to withdraw BTC from their DeFi or imported wallets. Please bear with us as we thoroughly investigate this matter. Our team is actively working on finding a solution to resolve this issue as quickly as possible.

Mon, Apr 8, 2024, 12:25 PM