Issue with 2FA SMS Deliverability in the USA
Resolved

This incident has been resolved.

Tue, Jan 9, 2024, 11:17 AM
11 months ago
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved.

Tue, Jan 9, 2024, 11:17 AM
2 weeks earlier...

Investigating

We have identified a problem with a 3rd party vendor used to deliver SMS 2FA challenges in the USA. We are working with the vendor to resume normal service.

Thu, Dec 21, 2023, 06:51 PM