DOT deposits and withdrawals are delayed
Resolved

We are back at the chain tip. Deposits and withdrawals are normalized.

Fri, Dec 22, 2023, 12:33 AM
1 year ago
Affected components

No components marked as affected

Updates

Resolved

We are back at the chain tip. Deposits and withdrawals are normalized.

Fri, Dec 22, 2023, 12:33 AM
19h earlier...

Identified

Our DOT node is having some issues and we are fixing it. All funds are safe.

Thu, Dec 21, 2023, 05:29 AM