Connectivity issues
Resolved
Degraded performance

All systems are working. We are actively monitoring the current status.

Mon, Nov 25, 2024, 05:08 PM
1 month ago
Affected components
Updates

Resolved

All systems are working. We are actively monitoring the current status.

Mon, Nov 25, 2024, 05:08 PM

Investigating

We are currently investigating connectivity issues with our web platform.

Mon, Nov 25, 2024, 05:05 PM