Issue delivering emails
Resolved
Degraded performance

All systems are working. We are actively monitoring the current status.

Thu, Nov 28, 2024, 04:43 PM
1 month ago
Affected components
Updates

Resolved

All systems are working. We are actively monitoring the current status.

Thu, Nov 28, 2024, 04:43 PM

Monitoring

The email delivery service is running. We are monitoring the situation.

Thu, Nov 28, 2024, 04:35 PM
43m earlier...

Investigating

We have identified an issue with our email delivery service. Your funds are safe.

Thu, Nov 28, 2024, 03:52 PM