No components marked as affected
Resolved
All systems are working. We are actively monitoring the current status.
Identified
We are facing some issues with our NEAR nodes currently which is affecting deposits and withdrawals. Currently they are delayed. Rest assured funds are safe.