Issues in our tron node infra.
Resolved·Degraded performance

All systems are working. We are actively monitoring the current status.

Tue, Jun 24, 2025, 12:06 PM
(1 week ago)
·
Affected components
Updates

Resolved

All systems are working. We are actively monitoring the current status.

Tue, Jun 24, 2025, 12:06 PM

Monitoring

We fixed the issues and all systems recovered, we will be monitoring for the next few hours.

Mon, Jun 23, 2025, 02:07 PM(21 hours earlier)

Identified

Our team identified the issue. We are working on a fix.

Mon, Jun 23, 2025, 09:44 AM(4 hours earlier)

Investigating

Block processing. deposits and withdrawals on Tron is delayed. We are investigating the issue. Rest assured, funds are safe.

Mon, Jun 23, 2025, 08:51 AM(53 minutes earlier)