No components marked as affected
Resolved
All systems are working. We are actively monitoring the current status.
Investigating
Crypto and fiat withdrawals from the Trading Account are temporarily unavailable while we investigate an issue. We are working to restore service as quickly as possible