Resolved
This incident has been resolved.
Investigating
We are continuing to investigate this issue.
Investigating
Blockchain.com services will be unavailable from Monday May 9th from 7pm BST as we perform scheduled maintenance at this time.
As a result, you may experience problems accessing the following services:
Blockchain.com AppBlockhain.com ExchangeBlockchain.com WebsiteBlockchain.com Portal
Your funds are safe and we’re working hard to get our services back to you as soon as possible.