Stacks nodes are having issues
Resolved·Degraded performance

All systems are working. We are actively monitoring the current status.

Fri, Aug 1, 2025, 02:08 AM
(1 day ago)
·
Affected components
Updates

Resolved

All systems are working. We are actively monitoring the current status.

Fri, Aug 1, 2025, 02:08 AM

Identified

Stacks block processing is delayed causing delays in deposits/withdrawals.

Thu, Jul 31, 2025, 12:34 AM(1 day earlier)