Cardano deposits/withdrawals delayed
Resolved·Degraded performance

All systems are working. We are actively monitoring the current status.

Sun, Nov 23, 2025, 03:28 PM
(1 week ago)
·
Affected components
Other
Updates

Resolved

All systems are working. We are actively monitoring the current status.

Sun, Nov 23, 2025, 03:28 PM

Monitoring

We have implemented the fixes and we are monitoring the situation. Systems are working fine.

Sun, Nov 23, 2025, 11:22 AM(4 hours earlier)

Identified

We restored deposits/withdrawals in trading account. We continue working to normalize a situation everywhere.

Sat, Nov 22, 2025, 12:34 PM(22 hours earlier)

Identified

We are implementing a fix at the moment.

Fri, Nov 21, 2025, 01:17 PM(23 hours earlier)

Investigating

Seems Cardano network is having some issues and deposits/withdrawals are delayed. We are investigating the issue.

Fri, Nov 21, 2025, 10:59 AM(2 hours earlier)