No components marked as affected
Resolved
All systems are working. We are actively monitoring the current status.
Investigating
USD wires have been temporarily disabled for deposits and withdrawals. We are working to resolve the issue as quickly as possible. Alternative USD deposit and withdrawals are still available.