Naira (NGN) deposit issue
Resolved

All systems are working. We are actively monitoring the current status.

Thu, Jan 15, 2026, 12:15 PM
(2 weeks ago)
·
Affected components

No components marked as affected

Updates

Resolved

All systems are working. We are actively monitoring the current status.

Thu, Jan 15, 2026, 12:15 PM

Investigating

We are currently investigating reports of delays or failures affecting NGN deposits. Our team is working to identify the root cause with our payment partners. We apologize for the inconvenience.

Wed, Jan 14, 2026, 03:41 PM(20 hours earlier)