Degraded performance across most services
Resolved·Degraded performance

We have fixed All systems are working. We are actively monitoring the current status.

Fri, Jul 2, 2021, 12:31 PM
(4 years ago)
·
Affected components
Updates

Resolved

We have fixed All systems are working. We are actively monitoring the current status.

Fri, Jul 2, 2021, 12:31 PM

Investigating

We are investigating a spike in some of our backend services becoming unhealthy. You may experience degraded performance across the Blockchain.com Wallet and exchange for logging in, buy, sell, swap, withdrawals, balances and transaction history.

Fri, Jul 2, 2021, 11:52 AM(38 minutes earlier)