Degraded Performance across Wallet and Exchange
Incident Report for Blockchain
Resolved
This incident is now being resolved.
Posted Mar 31, 2022 - 08:15 UTC
Monitoring
A fix has been implemented and we are now monitoring Performance.

We are sorry for any inconvenience caused during this period.
Posted Mar 31, 2022 - 08:10 UTC
Update
Our Team are continuing to investigate the issue.

Customer Funds remain safe.

We are sorry for any inconvenience this may have caused.
Posted Mar 31, 2022 - 05:59 UTC
Update
Our Team are continuing their investigations and trying to identify and resolve the performance issues.

Customer Funds continue to remain safe.

We will continue to provide updates as soon as we have them.
Posted Mar 30, 2022 - 20:38 UTC
Investigating
We are aware that some customers are experiencing delays in processing buy orders.

Our team are investigating this as a priority and working to identify and resolve the problem.

Customers Funds remain safe.

We are sorry for any inconvenience this may have caused and will provide further updates as soon as we have them.
Posted Mar 30, 2022 - 18:28 UTC
This incident affected: The Exchange (Exchange) and Wallet.