App Loading Issue
Incident Report for Blockchain
Resolved
This incident has been resolved.
Posted Nov 29, 2022 - 21:15 UTC
Investigating
We are currently investigating an issue causing the Blockchain app to take more time than expected to load.
Posted Nov 29, 2022 - 20:28 UTC
This incident affected: Wallet.