Degraded Performance Across Wallet & Exchange
Incident Report for Blockchain
Resolved
This incident has been resolved.
Posted Aug 01, 2022 - 22:44 UTC
Update
We are continuing to investigate this issue.
Posted Aug 01, 2022 - 22:43 UTC
Update
Our team is progressing investigations to identify the main issues impacting some of our Customers ability to view their accounts.

Customers Funds continue to remain safe.

We thank you for your patience and are sorry for the inconvenience caused.

We will provide more updates as soon as we have them.
Posted Aug 01, 2022 - 14:34 UTC
Investigating
We are aware that some customers are experiencing issues viewing their accounts.

Our Engineering team is investigating this as a priority and working to identify and resolve the problem.

Customers Funds remain safe.

We are sorry for any inconvenience this may have caused and will provide further updates as soon as we have them.
Posted Aug 01, 2022 - 12:33 UTC
This incident affected: The Exchange (Exchange, .com) and Wallet.