Delayed NEAR payments
Incident Report for Blockchain
Resolved
This incident has been resolved.
Posted Mar 29, 2023 - 10:46 UTC
Investigating
Deposits/withdrawals are delayed for NEAR. We're working on a fix, your funds are safe.
Posted Mar 28, 2023 - 09:20 UTC
This incident affected: The Exchange (Exchange) and Wallet.