Degraded Performance, Wallet - Payment History
Incident Report for Blockchain
Resolved
This incident has been resolved.
Posted Mar 31, 2022 - 23:54 UTC
Monitoring
A temporary fix has been deployed to the issue with User's Payment history and further monitoring will continue in the morning.

Please be assured that during this period, all funds were safe.

We are sorry for any inconvenience caused.
Posted Mar 31, 2022 - 23:53 UTC
Investigating
We are currently investigating an issue that may cause customers payment history from within the wallet from displaying correctly.

Please rest assured that all funds are safe, and once this issue is resolved, all customers will be able to see their full payment history as normal.

We are sorry for any inconvenience this may cause.

A further update will be provided as soon as available.
Posted Mar 31, 2022 - 11:08 UTC
This incident affected: Wallet.