DOT deposits and withdrawals are delayed
Incident Report for Blockchain
Resolved
We are back at the chain tip. Deposits and withdrawals are normalized.
Posted Dec 22, 2023 - 00:33 UTC
Identified
Our DOT node is having some issues and we are fixing it. All funds are safe.
Posted Dec 21, 2023 - 05:29 UTC