Temporary Login Issue
Incident Report for Blockchain
Resolved
This incident has been resolved.
Posted Aug 31, 2022 - 21:57 UTC
Update
We are continuing to investigate this issue.
Posted Aug 31, 2022 - 21:57 UTC
Investigating
We are aware of an issue preventing some users from logging into their Blockchain.com accounts.

This is currently being investigated by our team. All user funds remain secure and will be accessible once the issue is resolved.

We apologize for any inconvenience this may be causing you, and will provide further updates as soon as they become available.
Posted Aug 31, 2022 - 20:27 UTC
This incident affected: The Exchange (Exchange) and Wallet.