Degraded Performance across Services
Resolved·Full outage

This incident has been resolved.

Mon, Jun 13, 2022, 08:43 PM
(3 years ago)
·
Affected components
Updates

Resolved

This incident has been resolved.

Mon, Jun 13, 2022, 08:43 PM

Monitoring

A fix has been implemented and we are monitoring the results. Rest assured that your funds are safe and that the issue is being monitored.

Mon, Jun 13, 2022, 06:24 PM(2 hours earlier)

Identified

The issue has been identified and a fix is being implemented.

Mon, Jun 13, 2022, 05:25 PM(59 minutes earlier)

Investigating

We are continuing to investigate this issue.

Mon, Jun 13, 2022, 05:04 PM(20 minutes earlier)

Investigating

We are experiencing an issue that’s making it difficult for some users to log in to their Blockchain.com account. Rest assured that your funds are safe and that the issue is being investigated.

Mon, Jun 13, 2022, 04:47 PM(16 minutes earlier)