Balance Display Issue
Incident Report for Blockchain
Resolved
This incident has been resolved.
Posted Jun 30, 2022 - 17:10 UTC
Update
We are continuing to investigate this issue.
Posted Jun 30, 2022 - 11:51 UTC
Investigating
We have received reports from several users that their balances are not being updated.

Our engineering team are investigating this and we will provide an update shortly.

We apologise for any inconvenience this has caused.
Posted Jun 30, 2022 - 11:51 UTC
This incident affected: The Exchange (Exchange) and Wallet.