May 9th 2023 Scheduled Maintenance
Resolved·Under maintenance

This incident has been resolved.

Tue, May 9, 2023, 08:15 PM
(2 years ago)
·
Affected components
Exchange
Updates

Resolved

This incident has been resolved.

Tue, May 9, 2023, 08:15 PM

Investigating

We are continuing to investigate this issue.

Tue, May 9, 2023, 07:43 PM(32 minutes earlier)

Investigating

Blockchain.com services will be unavailable from Monday May 9th from 7pm BST as we perform scheduled maintenance at this time.

As a result, you may experience problems accessing the following services:

Blockchain.com AppBlockhain.com ExchangeBlockchain.com WebsiteBlockchain.com Portal

Your funds are safe and we’re working hard to get our services back to you as soon as possible.

Tue, May 9, 2023, 05:56 PM(1 hour earlier)