Degraded Performance across Wallet and Exchange
Incident Report for Blockchain
Resolved
This incident has been resolved.
Posted Mar 24, 2022 - 00:22 UTC
Monitoring
Our services are back up. We are continuing to monitor performance through the coming hours.
Posted Mar 23, 2022 - 13:37 UTC
Update
We are continuing to investigate the issue. Login, balances, brokerage and activity are showing degraded performance.
Posted Mar 23, 2022 - 13:04 UTC
Investigating
We are currently investigating an issue that is leading to degraded performance across the Wallet and Exchange. Users might experience delays while logging into the products or performing actions.
Posted Mar 23, 2022 - 11:09 UTC
This incident affected: The Exchange (Exchange) and Wallet.