Issue with 2FA SMS Deliverability in the USA
Incident Report for Blockchain
Resolved
This incident has been resolved.
Posted Jan 09, 2024 - 11:17 UTC
Investigating
We have identified a problem with a 3rd party vendor used to deliver SMS 2FA challenges in the USA. We are working with the vendor to resume normal service.
Posted Dec 21, 2023 - 18:51 UTC
This incident affected: Wallet.