Stablecoins update
Resolved·Partial outage

This incident has been resolved.

Mon, Mar 13, 2023, 12:55 PM
(2 years ago)
·
Affected components
Updates

Resolved

This incident has been resolved.

Mon, Mar 13, 2023, 12:55 PM

Monitoring

We have temporarily paused PAX and USDC automatic conversion on the Exchange. We are watching the market closely, and plan to re-commence conversions soon. We thank you for your patience.Your assets remain safe and are available for on-chain sends.

Sat, Mar 11, 2023, 02:35 PM(1 day earlier)