Temporary Login Issue
Resolved·Partial outage

This incident has now been successfully resolved.

Thank you for your patience whilst we were working to resolve this issue.

Thu, Jul 21, 2022, 12:21 PM
(2 years ago)
·
Affected components
Updates

Resolved

This incident has now been successfully resolved.

Thank you for your patience whilst we were working to resolve this issue.

Thu, Jul 21, 2022, 12:21 PM

Identified

Our team has identified the issue and a fix is being implemented.

We are sorry for any inconvenience caused during this period.

Please note that all User funds remain safe and we will provide further updates soon.

Thu, Jul 21, 2022, 10:04 AM(2 hours earlier)

Investigating

We are continuing to investigate this issue.

Thu, Jul 21, 2022, 09:57 AM

Investigating

We are aware of an issue preventing some users from logging into their Blockchain.com Accounts. The team are working hard to resolve the issue as quickly as possible. All user funds are secure and will be accessible once the issue is resolved.

Thu, Jul 21, 2022, 03:40 AM(6 hours earlier)