TRX deposit & withdrawal processing delays
Resolved·Degraded performance

We think the impact from the issue is over.

Sat, Nov 19, 2022, 07:46 PM
(2 years ago)
·
Affected components
Updates

Resolved

We think the impact from the issue is over.

Sat, Nov 19, 2022, 07:46 PM

Identified

Deposit & withdrawal processing issues for Cardano (ADA) has been resolved, we are continuing to work on a fix for Tron (TRX).

We are sorry for any inconvenience caused and will provide more updates when they become available.

Thu, Nov 17, 2022, 12:45 PM(2 days earlier)

Identified

Our Engineers continue to make progress towards a fix on this issue.

All customer funds remain safe and secure.

We are sorry for any inconvenience caused and will provide more updates when they become available.

Tue, Nov 15, 2022, 12:38 AM(2 days earlier)

Identified

Our Engineers continue to make progress towards a fix on this issue.

All customer funds remain safe and secure.

We are sorry for any inconvenience caused and will provide more updates when they become available.

Mon, Nov 14, 2022, 09:50 AM(14 hours earlier)

Identified

Our Engineers are continuing to work on a fix for this issue as transactions related to these currencies are experiencing some delays.

All customer funds remain safe and secure.

We are sorry for any inconvenience caused and will provide more updates when they become available.

Sun, Nov 13, 2022, 09:17 PM(12 hours earlier)

Identified

Deposits & withdrawals processing for Cardano (ADA) & Tron (TRX) is currently delayed

Sun, Nov 13, 2022, 08:58 PM(19 minutes earlier)