TRX deposit & withdrawal processing delays
Resolved·Degraded performance

This incident has been resolved.

Sat, Feb 4, 2023, 04:49 PM
(2 years ago)
·
Affected components
Updates

Resolved

This incident has been resolved.

Sat, Feb 4, 2023, 04:49 PM

Investigating

Deposits & withdrawals processing for Tron (TRX) is currently delayed, our engineers are currently working on a fix.

Please accept our sincerest apologies for the inconvenience caused.

Fri, Feb 3, 2023, 01:28 PM(1 day earlier)