Degraded Performance on Exchange
Resolved·Degraded performance

This incident has been resolved.

Wed, May 11, 2022, 05:32 PM
(3 years ago)
·
Affected components
Updates

Resolved

This incident has been resolved.

Wed, May 11, 2022, 05:32 PM

Investigating

We are aware that some customers are experiencing delays Exchange orderbook.

Our team is investigating this as a priority and working to identify and resolve the problem.

Customers' Funds remain safe.

We are sorry for any inconvenience this may have caused and will provide further updates as soon as we have them.

Wed, May 11, 2022, 03:26 PM(2 hours earlier)