Scheduled maintenance - April 17th 2023
Complete
Under maintenanceApr 17, 6:00 PM - 10:00 PM

The scheduled maintenance has been completed.

Mon, Apr 17, 2023, 10:01 PM
1 year ago
Affected components
Exchange
Updates

Complete

The scheduled maintenance has been completed.

Mon, Apr 17, 2023, 10:01 PM
53m earlier...

In progress

Scheduled maintenance is still in progress. We will provide updates as necessary.

Mon, Apr 17, 2023, 09:07 PM
3h earlier...

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.

Mon, Apr 17, 2023, 06:00 PM
47m earlier...

Scheduled

Blockchain.com services will be unavailable on Monday April 17th from 7pm BST as we perform scheduled maintenance at this time.

As a result, you may experience problems accessing the following services:

Blockchain.com AppBlockhain.com ExchangeBlockchain.com WebsiteBlockchain.com Portal

Your funds are safe and we’re working hard to get our services back to you as soon as possible.

Mon, Apr 17, 2023, 05:13 PM