Degraded Performance Across Wallet & Exchange
Incident Report for Blockchain
Resolved
This incident has now been resolved.
Posted Nov 10, 2022 - 13:55 UTC
Identified
Our Engineers have identified the issue and a fix is being applied.

Please be reassured that All Customer Funds remain safe and secure.

We will provide more updates as soon as we have them.
Posted Nov 10, 2022 - 13:52 UTC
Investigating
We are currently investigating reports indicating a problem with trading via our Brokerage & Exchange Services for some Users.

We would like to reassure you that All Customer Funds remain safe and secure.

We are sorry for any inconvenience caused and will provide more updates as soon as they are available.
Posted Nov 10, 2022 - 13:44 UTC
This incident affected: The Exchange (Exchange) and Wallet.