Ethereum payment processing delays for Trading Account
Incident Report for Blockchain
Resolved
All systems are working. We are actively monitoring the current status.
Posted Apr 29, 2024 - 01:07 UTC
Monitoring
Our team has deployed a fix, our systems should catch up with the network soon
Posted Apr 28, 2024 - 21:58 UTC
Investigating
Our Ethereum payments processing infrastructure is experiencing issues which is causing transaction processing delay for Trading Account. Our team is working on resolution. All funds are safe
Posted Apr 28, 2024 - 19:50 UTC
This incident affected: Wallet.