Degraded performance on Blockchain.com services
Resolved·Full outage

This incident has now been resolved.

Sun, Aug 28, 2022, 04:13 AM
(2 years ago)
·
Affected components
Updates

Resolved

This incident has now been resolved.

Sun, Aug 28, 2022, 04:13 AM

Identified

Our Engineers have identified the issue and are working on applying a fix.

Customer Funds remain secure and will be visible once the issue is resolved.

We are sorry for any inconvenience caused and will continue to provide updates as they become available.

Sun, Aug 28, 2022, 02:22 AM(1 hour earlier)

Investigating

We are investigating a performance issue that may result in some users being unable to load their Blockchain.com account. Customer funds remain secure, and will be accessible once the issue is resolved. We apologize for any inconvenience this may be causing you, and will continue to provide updates as they become available.

Sun, Aug 28, 2022, 01:11 AM(1 hour earlier)